Started over 3 years agoApril 19, 2023Lasted about 1 hourApril 19, 20233:524:41 PMUTC
Affected
Hosted VoIP - M
Operational from 3:52 PM to 4:41 PM
Updates
Resolved
UTC
Resolved
UTC
The issue has been identified and resolved at this time. All services are returning to normal status. An RFO (reason for outage ) will be posted within the next 48 hours.
Investigating
UTC
Investigating
UTC
We are currently investigating a regional connection issue that may impact some customers. We will provide more information as it is available.